Back to overview
Downtime

aleph.investigativedata.org, auth.investigativedata.org, and 1 other service are down

Jul 06 at 08:06am CEST
Affected services
aleph.investigativedata.org
auth.investigativedata.org
investigraph.dev

Resolved
Jul 06 at 08:14am CEST

investigraph.dev recovered.

Updated
Jul 06 at 08:10am CEST

aleph.investigativedata.org and auth.investigativedata.org recovered.

Created
Jul 06 at 08:06am CEST

aleph.investigativedata.org, auth.investigativedata.org, and investigraph.dev went down.